aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-bsp/ledmon
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
index f9ae9aad9a..66da1826fc 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
@@ -13,7 +13,7 @@ DEPENDS = "sg3-utils udev"
inherit autotools systemd
-SYSTEMD_SERVICE_${PN} = "ledmon.service"
+SYSTEMD_SERVICE:${PN} = "ledmon.service"
# 0.93
SRC_URI = "git://github.com/intel/ledmon;branch=master \
@@ -24,7 +24,7 @@ SRC_URI = "git://github.com/intel/ledmon;branch=master \
SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e"
COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
-COMPATIBLE_HOST_libc-musl = "null"
+COMPATIBLE_HOST:libc-musl = "null"
S = "${WORKDIR}/git"
EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
@@ -33,7 +33,7 @@ EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
# We need to add this include path in CFLAGS.
CFLAGS += "-I${S}/config"
-do_install_append() {
+do_install:append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system