aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2023-11-18 12:52:25 +0300
committerKhem Raj <raj.khem@gmail.com>2023-11-18 08:45:56 -0800
commitf13feb0adfe150c922756eef366a69ccb1f1c49f (patch)
tree81616644bf4e3a0cc2a26d0dc3f59b189e68fe68 /meta-oe/recipes-bsp/ledmon
parent1ae1a7cd36240b259ea56b25a7d8a86d8dcae5a0 (diff)
downloadmeta-openembedded-f13feb0adfe150c922756eef366a69ccb1f1c49f.tar.gz
ledmon: upgrade 0.93 -> 0.97
* Added 0001-fix-build-with-clang.patch to fix build error caused by missing 'value' initializer * License changed GPL-2.0-only -> LGPL-2.0-only - LIC_FILES_CHKSUM changed COPYING -> COPYING.LIB for LGPL-2.0-only - Changed license headers in required source files. - Changed copyright years to 2022 in modified files. * 0001-Don-t-build-with-Werror-to-fix-compile-error.patch removed because fixed in the new version. * libpci was added as depends following this error -> configure: error: Package requirements (libpci) were not met: No package 'libpci' found * pkgconfig added as inherit following this error -> PKG_PROG_PKG_CONFIG: command not found Changelog: It can be followed here: https://github.com/intel/ledmon/releases Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch30
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch90
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb (renamed from meta-oe/recipes-bsp/ledmon/ledmon_git.bb)18
3 files changed, 98 insertions, 40 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch
deleted file mode 100644
index 09f4993a25..0000000000
--- a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Subject: [PATCH] Don't build with -Werror to fix compile error.
-
-| 550 | _dump_sgpio_amd(&amd_reg->amd);
-| | ^~~~~~~~~~~~~
-| amd_sgpio.c: In function '_write_amd_register':
-| amd_sgpio.c:558:18: error: taking address of packed member of 'struct amd_register' may result in an unaligned pointer value [-Werror=address-of-packed-member]
-
-Upstream-Status: Submitted
-https://github.com/intel/ledmon/pull/48/commits
-
-Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
----
- configure.ac | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 7bc20f8..7e01bd5 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -22,7 +22,6 @@ AX_AM_CFLAGS_ADD([-Werror=format-truncation=1])
- AX_AM_CFLAGS_ADD([-Werror=shift-negative-value])
- AX_AM_CFLAGS_ADD([-Werror=alloca])
- AX_AM_CFLAGS_ADD([-Werror=missing-field-initializers])
--AX_AM_CFLAGS_ADD([-Werror])
- AX_AM_CFLAGS_ADD([-Werror=format-signedness])
-
- AC_SUBST([AM_CFLAGS])
---
-2.7.4
-
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch
new file mode 100644
index 0000000000..f1e1d6f780
--- /dev/null
+++ b/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch
@@ -0,0 +1,90 @@
+From 28fd86fb4e18af181174176530a80672de4449d2 Mon Sep 17 00:00:00 2001
+From: alperak <alperyasinak1@gmail.com>
+Date: Sat, 18 Nov 2023 12:27:17 +0300
+Subject: [PATCH] fix build with clang
+
+struct ibpi2value is a structure which contains 2 unsigned integers. In
+a number of cases the code was not initializing a value for the last value
+in the pair in struct ibpi2value ibpi_to_attention. This was raised when
+using clang compiler.
+
+vmdssd.c:49:27: error: missing field 'value' initializer
+[-Werror,-Wmissing-field-initializers]
+ {LED_IBPI_PATTERN_UNKNOWN}
+
+dellssd.c:74:27: error: missing field 'value' initializer
+[-Werror,-Wmissing-field-initializers]
+ {LED_IBPI_PATTERN_UNKNOWN}
+
+amd_ipmi.c:57:27: error: missing field 'value'
+initializer [-Werror,-Wmissing-field-initializers]
+ {LED_IBPI_PATTERN_UNKNOWN}
+
+npem.c:76:27: error: missing field 'value'
+initializer [-Werror,-Wmissing-field-initializers]
+ {LED_IBPI_PATTERN_UNKNOWN}
+
+Upstream-Status: Submitted [https://github.com/intel/ledmon/pull/179]
+Signed-off-by: alperak <alperyasinak1@gmail.com>
+---
+ src/amd_ipmi.c | 2 +-
+ src/dellssd.c | 2 +-
+ src/npem.c | 2 +-
+ src/vmdssd.c | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/amd_ipmi.c b/src/amd_ipmi.c
+index 726f77d..ad36e9e 100644
+--- a/src/amd_ipmi.c
++++ b/src/amd_ipmi.c
+@@ -53,7 +53,7 @@ const struct ibpi2value ibpi2amd_ipmi[] = {
+ {IBPI_PATTERN_FAILED_ARRAY, 0x45},
+ {IBPI_PATTERN_REBUILD, 0x46},
+ {IBPI_PATTERN_HOTSPARE, 0x47},
+- {IBPI_PATTERN_UNKNOWN}
++ {IBPI_PATTERN_UNKNOWN, 0}
+ };
+
+ #define MG9098_CHIP_ID_REG 0x63
+diff --git a/src/dellssd.c b/src/dellssd.c
+index 3c10ec7..7f02ea1 100644
+--- a/src/dellssd.c
++++ b/src/dellssd.c
+@@ -71,7 +71,7 @@ static const struct ibpi2value ibpi2ssd[] = {
+ {IBPI_PATTERN_FAILED_DRIVE, BP_FAULT | BP_ONLINE},
+ {IBPI_PATTERN_LOCATE, BP_IDENTIFY | BP_ONLINE},
+ {IBPI_PATTERN_LOCATE_OFF, BP_ONLINE},
+- {IBPI_PATTERN_UNKNOWN}
++ {IBPI_PATTERN_UNKNOWN, 0}
+ };
+
+ #define DELL_OEM_NETFN 0x30
+diff --git a/src/npem.c b/src/npem.c
+index c21276d..3499169 100644
+--- a/src/npem.c
++++ b/src/npem.c
+@@ -72,7 +72,7 @@ const struct ibpi2value ibpi_to_npem_capability[] = {
+ {IBPI_PATTERN_FAILED_DRIVE, PCI_NPEM_FAIL_CAP},
+ {IBPI_PATTERN_LOCATE, PCI_NPEM_LOCATE_CAP},
+ {IBPI_PATTERN_LOCATE_OFF, PCI_NPEM_OK_CAP},
+- {IBPI_PATTERN_UNKNOWN}
++ {IBPI_PATTERN_UNKNOWN, 0}
+ };
+
+ static struct pci_access *get_pci_access()
+diff --git a/src/vmdssd.c b/src/vmdssd.c
+index 51af591..9c63d90 100644
+--- a/src/vmdssd.c
++++ b/src/vmdssd.c
+@@ -45,7 +45,7 @@ struct ibpi2value ibpi_to_attention[] = {
+ {IBPI_PATTERN_REBUILD, ATTENTION_REBUILD},
+ {IBPI_PATTERN_LOCATE_OFF, ATTENTION_OFF},
+ {IBPI_PATTERN_ONESHOT_NORMAL, ATTENTION_OFF},
+- {IBPI_PATTERN_UNKNOWN}
++ {IBPI_PATTERN_UNKNOWN, 0}
+ };
+
+ #define SYSFS_PCIEHP "/sys/module/pciehp"
+--
+2.25.1
+
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
index dbfd1e7bc0..d431fd9a84 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
@@ -5,28 +5,26 @@ DESCRIPTION = "The utilities are designed primarily to be used on storage server
"
HOMEPAGE = "https://github.com/intel/ledmon"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
-"
+LICENSE = "LGPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
-DEPENDS = "sg3-utils udev"
+DEPENDS = "sg3-utils udev pciutils"
-inherit autotools systemd
+inherit autotools systemd pkgconfig
SYSTEMD_SERVICE:${PN} = "ledmon.service"
-# 0.93
SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \
- file://0002-include-sys-select.h-and-sys-types.h.patch \
- file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \
- "
+ file://0002-include-sys-select.h-and-sys-types.h.patch \
+ file://0001-fix-build-with-clang.patch"
-SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e"
+SRCREV = "b0edae14e8660b80ffe0384354038a9f62e2978d"
COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
COMPATIBLE_HOST:libc-musl = "null"
S = "${WORKDIR}/git"
+
EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.