aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-01 13:38:18 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-01 09:00:00 +0200
commitc4f636ad336bf33d986f2bd11086067c18ea5bcc (patch)
tree9ad22fd013e801b1b46d5bf65d8512e1ce8dc1fa /meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
parent56485baea55de18ab22ca82ebaebdbfed1b353bc (diff)
downloadmeta-openembedded-c4f636ad336bf33d986f2bd11086067c18ea5bcc.tar.gz
systemd_git.bb: Alias mkostemp() to mkstemp() for uclibc targets
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch b/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
new file mode 100644
index 0000000000..ca10440a8d
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
@@ -0,0 +1,19 @@
+uclibc does not have mkostemp() so we redefine it to use mkstemp()
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: git/src/macro.h
+===================================================================
+--- git.orig/src/macro.h 2011-06-30 10:33:53.000000000 -0700
++++ git/src/macro.h 2011-06-30 15:07:28.285270006 -0700
+@@ -27,6 +27,10 @@
+ #include <sys/uio.h>
+ #include <inttypes.h>
+
++#ifdef __UCLIBC__
++/* uclibc does not implement mkostemp GNU extention */
++#define mkostemp(x,y) mkstemp(x)
++#endif
+ #define _printf_attr_(a,b) __attribute__ ((format (printf, a, b)))
+ #define _sentinel_ __attribute__ ((sentinel))
+ #define _noreturn_ __attribute__((noreturn))