aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb
diff options
context:
space:
mode:
authorHong Liu <hongl.fnst@cn.fujitsu.com>2018-10-17 08:42:33 +0800
committerKhem Raj <raj.khem@gmail.com>2018-10-16 21:23:47 -0700
commitdf9f15caaaa9280aa7c495cf50d2cd7e242cd8b1 (patch)
tree93f2e6bc898078d02ac871dcf85649dc950b16fb /meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb
parent02fd0518c00e6316e90bef077f55156ebb75eb8d (diff)
downloadmeta-openembedded-df9f15caaaa9280aa7c495cf50d2cd7e242cd8b1.tar.gz
ipc-run: 0.99->20180523.0
1.Upgrade ipc-run from 0.99 to 20180523.0 Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb')
-rw-r--r--meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb b/meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb
new file mode 100644
index 0000000000..c812ae1374
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/ipc-run_20180523.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "\
+IPC::Run allows you run and interact with child processes \
+using files, pipes, and pseudo-ttys. Both system()-style and scripted \
+usages are supported and may be mixed. Likewise, functional and OO API \
+styles are both supported and may be mixed."
+HOMEPAGE = "https://metacpan.org/release/IPC-Run"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
+DEPENDS = "perl"
+
+SRC_URI = "git://github.com/toddr/IPC-Run.git"
+SRCREV = "0b409702490729eeb97ae65f5b94d949ec083134"
+
+S = "${WORKDIR}/git"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}