aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-18 19:42:59 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-19 11:02:29 -0800
commit2f6c043c0c99ccf71f9eb9088adbe42972b9d8a0 (patch)
tree772cc002d32aa8acb04c93f923966d4b8ec86864 /meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch
parentc8c31eef9f4a32c852ab51ec31a90f55e4d685b7 (diff)
downloadmeta-openembedded-2f6c043c0c99ccf71f9eb9088adbe42972b9d8a0.tar.gz
hiredis: Upgrade to 0.14.0
* Define LIBRARY_PATH so multilibbed version can install correctly * Forward port patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch')
-rw-r--r--meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch16
1 files changed, 6 insertions, 10 deletions
diff --git a/meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch b/meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch
index fef2bc7541..1af5d26ac0 100644
--- a/meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch
+++ b/meta-oe/recipes-extended/hiredis/files/0001-Makefile-remove-hardcoding-of-CC.patch
@@ -11,22 +11,18 @@ Signed-off-by: Andrea Galbusera <gizero@gmail.com>
Makefile | 5 -----
1 file changed, 5 deletions(-)
-diff --git a/Makefile b/Makefile
-index 8b0f0c2..66a4317 100644
--- a/Makefile
+++ b/Makefile
-@@ -34,11 +34,6 @@ define REDIS_TEST_CONFIG
+@@ -35,12 +35,6 @@ define REDIS_TEST_CONFIG
endef
export REDIS_TEST_CONFIG
-# Fallback to gcc when $CC is not in $PATH.
--CC:=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
+-CC:=$(shell sh -c 'type $${CC%% *} >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
+-CXX:=$(shell sh -c 'type $${CXX%% *} >/dev/null 2>/dev/null && echo $(CXX) || echo g++')
-OPTIMIZATION?=-O3
-WARNINGS=-Wall -W -Wstrict-prototypes -Wwrite-strings
--DEBUG?= -g -ggdb
- REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG) $(ARCH)
- REAL_LDFLAGS=$(LDFLAGS) $(ARCH)
+-DEBUG_FLAGS?= -g -ggdb
+ REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG_FLAGS)
+ REAL_LDFLAGS=$(LDFLAGS)
---
-1.9.1
-