aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/openwsman
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commit21f10c11f39020f9502d741c774a12d1aeb39499 (patch)
treefdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-extended/openwsman
parent723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff)
downloadmeta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/openwsman')
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
index bdb7ced17c..52b271c114 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
@@ -29,7 +29,7 @@ inherit systemd cmake pkgconfig pythonnative perlnative
SYSTEMD_SERVICE_${PN} = "openwsmand.service"
SYSTEMD_AUTO_ENABLE = "disable"
-LDFLAGS_append = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
+LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
-DBUILD_LIBCIM=NO \
@@ -50,7 +50,7 @@ do_install_append() {
install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
- if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}/${systemd_unitdir}/system
install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system