aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/wxwidgets
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-08 11:41:46 -0400
committerKhem Raj <raj.khem@gmail.com>2022-04-10 10:05:35 -0700
commit5e5d973d7811d75203cb783dd2b2e5cf0cd41efe (patch)
treecd538ecf3e3e349b8118d660e6a676ad5ef8356b /meta-oe/recipes-extended/wxwidgets
parentb04696ddf8da4aec9d8020ff6dc49b8430e4eb50 (diff)
downloadmeta-openembedded-5e5d973d7811d75203cb783dd2b2e5cf0cd41efe.tar.gz
wxwidgets: Fix building without x11
Building with wayland and opengl in DISTRO_FEATURES without x11 as well was giving the error: wxwidgets: PACKAGECONFIG[no_gui] Conflict package config 'opengl' set in PACKAGECONFIG. Upon some investigation, it looks like wxwidgets now supports building against Gtk's Wayland support, so we can also enable it if wayland is in DISTRO_FEATURES. For OpenGL, however, wxwidgets seems to have a dependency on libglu, so the DISTRO_FEATURES check has been changed to only enable it by default if both x11 and opengl are configured. Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-oe/recipes-extended/wxwidgets')
-rw-r--r--meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb b/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb
index 87fd284ae5..6b57cb54cb 100644
--- a/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb
+++ b/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb
@@ -45,9 +45,9 @@ EXTRA_OECMAKE:append:libc-musl = " \
"
EXTRA_OECMAKE:append:class-target = ' -DEGREP="/bin/grep -E"'
-# All toolkit-configs except 'no_gui' require x11 explicitly (see toolkit.cmake)
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', 'no_gui', d)} \
- ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)} \
+# OpenGL support currently seems tied to using libglu, which requires x11
+PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', 'x11 wayland', 'gtk', 'no_gui', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)} \
"
PACKAGECONFIG:remove:class-native = "opengl"