aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/surf/surf_2.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-12-12 20:57:52 -0800
committerKhem Raj <raj.khem@gmail.com>2021-12-13 08:15:33 -0800
commite89b06a05a6b6543103c77b0ab70e5915b7f2021 (patch)
tree12e8e665dc245f431f5fd9d6276852f3f03d8c61 /meta-oe/recipes-graphics/surf/surf_2.1.bb
parentabea11781a677011cbebb42582b2cde8e527bdfe (diff)
downloadmeta-openembedded-e89b06a05a6b6543103c77b0ab70e5915b7f2021.tar.gz
surf: Add soup3 patch conditionally
This patch is only needed when webkit is compiled with soup3 support Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Joshua Watt <JPEWhacker@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/surf/surf_2.1.bb')
-rw-r--r--meta-oe/recipes-graphics/surf/surf_2.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/surf/surf_2.1.bb b/meta-oe/recipes-graphics/surf/surf_2.1.bb
index 710ed9bce9..51c14624af 100644
--- a/meta-oe/recipes-graphics/surf/surf_2.1.bb
+++ b/meta-oe/recipes-graphics/surf/surf_2.1.bb
@@ -9,16 +9,20 @@ DEPENDS = "webkitgtk gtk+3 glib-2.0 gcr"
REQUIRED_DISTRO_FEATURES = "x11 opengl"
+SRCREV = "bcd7d74e613fb8af11b40c351f0a6c1a771b2d2b"
SRC_URI = "git://git.suckless.org/surf;branch=surf-webkit2 \
- file://0001-config.mk-Fix-compiler-and-linker.patch \
- file://0001-config.ml-make-compatible-with-webkitgtk-2.34.0.patch \
"
-SRCREV = "bcd7d74e613fb8af11b40c351f0a6c1a771b2d2b"
+SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'soup3', 'file://0001-config.mk-Fix-compiler-and-linke,ig.ml-make-compatible-with-webkitgtk-2.34.0.patch', '', d)}"
S = "${WORKDIR}/git"
inherit pkgconfig features_check
+PACKAGECONFIG ?= ""
+
+# Enable if soup3 is enabled in webkit recipe
+PACKAGECONFIG[soup3] = ",,,"
+
TARGET_CC_ARCH += "${LDFLAGS}"
do_install () {