aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorDenys Zagorui <dzagorui@cisco.com>2023-09-01 05:56:53 -0700
committerKhem Raj <raj.khem@gmail.com>2023-09-07 08:22:43 -0700
commit0bcfd6291f2dbdb96ccbd89527b891a796b34063 (patch)
tree977f4d2a94899e29698f4724a924ce1ca9f272ae /meta-oe/recipes-kernel
parent10e2559081092e8eae6bd0add2a4f90c33d674a3 (diff)
downloadmeta-openembedded-0bcfd6291f2dbdb96ccbd89527b891a796b34063.tar.gz
bpftool: add native and nativesdk support
There are issues with nativesdk variant ... ERROR: nativesdk-bpftool-1.0-r0 do_package: QA Issue: nativesdk-bpftool: Files/directories were installed but not shipped in any package: /usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-xesdk-linux/usr/sbin/bpftool /usr/share/bash-completion/completions/bpftool ... nativesdk.bbclass sets sbindir = "${bindir}" but bpftool is installed under sbin to fix that add sbin to FILES for bpftool completions {prefix} is not used but it seems that bitbake expects that installed files should be perfixed with "${SDKPATHNATIVE}${prefix_nativesdk}" to fix that override bash_compdir Signed-off-by: Denys Zagorui <dzagorui@cisco.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index bbfab47aae..317ec19266 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -18,6 +18,7 @@ EXTRA_OEMAKE = "\
LD="${LD}" \
AR=${AR} \
ARCH=${ARCH} \
+ bash_compdir=${prefix}/share/bash-completion \
"
SECURITY_CFLAGS = ""
@@ -42,3 +43,7 @@ python do_package:prepend() {
}
B = "${WORKDIR}/${BPN}-${PV}"
+
+FILES:${PN} += "${exec_prefix}/sbin/*"
+
+BBCLASSEXTEND = "native nativesdk"