aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorDenys Zagorui <dzagorui@cisco.com>2023-05-23 07:00:20 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-23 23:08:06 -0700
commit3de33c7ecc9998049f69d5eb668023f607537f15 (patch)
tree4ecb237ecb5ddec02669867b9a939e0b568c0845 /meta-oe/recipes-kernel
parent4a602cb1f3f9373df4d755dba70166b6728930e7 (diff)
downloadmeta-openembedded-3de33c7ecc9998049f69d5eb668023f607537f15.tar.gz
bpftool: Fix externalsrc support
When the externalsrc class is used the tasks listed in SRCTREECOVEREDTASKS are deleted to prevent them being executed. If externalsrc is used for the kernel then this will include virtual/kernel:do_patch. We can depend on do_shared_workdir instead as this will survive when externalsrc is used. Similar to [openembedded-core] (eab605bab945 "perf: Fix externalsrc support") Signed-off-by: Denys Zagorui <dzagorui@cisco.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index 67a821c07c..d4286295c0 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -7,7 +7,7 @@ PROVIDES = "virtual/bpftool"
inherit bash-completion kernelsrc kernel-arch
-do_populate_lic[depends] += "virtual/kernel:do_patch"
+do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
EXTRA_OEMAKE = "\
V=1 \
@@ -22,8 +22,6 @@ EXTRA_OEMAKE = "\
SECURITY_CFLAGS = ""
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
-
COMPATIBLE_HOST = "(x86_64|aarch64).*-linux"
COMPATIBLE_HOST:libc-musl = 'null'