aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorJohnathan Mantey <johnathanx.mantey@intel.com>2023-11-02 10:27:36 -0700
committerKhem Raj <raj.khem@gmail.com>2023-11-02 10:45:57 -0700
commit762a6880f3e56832441ecacdddeddc3566de1f54 (patch)
tree37c05480f9e18583e5f2f3f38efbe56a166f0a84 /meta-oe/recipes-kernel
parent3b1abede06befcef54ffacf086d985f7283dd8c2 (diff)
downloadmeta-openembedded-762a6880f3e56832441ecacdddeddc3566de1f54.tar.gz
ipmitool: Update and eliminate unneeded patch
The upstream ipmitool code has implemented an autoconfig control to enable and disable dynamic fetching of the IANA numbers file. As a result the patch removing the code that blocks fetching the IANA numbers is no longer relevant. The patch being removed explicitlly blocks downloading the IANA numbers file. Maintain this behavior at this level by using the --disable-registry-download feature. In order for that autoconfig switch to work, the recipe must inherit the pkgconfig feature. Without the pkgconfig dependency the code in the configure.ac file causes a compile time error. Tested: IANA numbers file isn't downloaded. Manually downloaded IANA file is installed in /usr/share/misc Enabling registry download enables dynamic download of IANA numbers Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch41
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb12
2 files changed, 8 insertions, 45 deletions
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch b/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
deleted file mode 100644
index 442f132718..0000000000
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 63d72f97bd106dd2101cd7fdac6df4f7a053d67c Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 2 Sep 2022 08:27:39 -0700
-Subject: [PATCH] configure: Remove the logic to download IANA PEN database
- during configure
-
-OE will do all downloading before it starts to configure therefore this
-step is moved out into bitbake recipe, so we can make it immutable build
-
-Upstream-Status: Inappropriate [OE-Specific]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- configure.ac | 16 +---------------
- 1 file changed, 1 insertion(+), 15 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -56,21 +56,7 @@ if test "x$exec_prefix" = "xNONE"; then
- exec_prefix="$prefix"
- fi
-
--if test "x$WGET" = "x"; then
-- if test "x$CURL" = "x"; then
-- AC_MSG_WARN([** Neither wget nor curl could be found.])
-- AC_MSG_WARN([** IANA PEN database will not be installed by `make install` !])
-- else
-- DOWNLOAD="$CURL --location --progress-bar"
-- AM_CONDITIONAL([DOWNLOAD], [true])
-- fi
--else
-- DOWNLOAD="$WGET -c -nd -O -"
-- AM_CONDITIONAL([DOWNLOAD], [true])
--fi
--
--AC_MSG_WARN([** Download is:])
--AC_MSG_WARN($DOWNLOAD)
-+AM_CONDITIONAL([DOWNLOAD], [false])
- AC_SUBST(DOWNLOAD, $DOWNLOAD)
-
- dnl
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
index ab9074bba5..a8279f5755 100644
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
+++ b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
@@ -21,10 +21,9 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
DEPENDS = "openssl readline ncurses"
-SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62"
+SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
${IANA_ENTERPRISE_NUMBERS} \
- file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \
"
IANA_ENTERPRISE_NUMBERS ?= ""
@@ -34,7 +33,7 @@ IANA_ENTERPRISE_NUMBERS ?= ""
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools pkgconfig
do_install:append() {
if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
@@ -50,5 +49,10 @@ FILES:${PN} += "${datadir}/misc"
# --enable-file-security adds some security checks
# --disable-intf-free disables FreeIPMI support - we don't want to depend on
# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
+# --disable-registry-download prevents the IANA numbers from being fetched
+# at build time, as it is not repeatable.
#
-EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free"
+EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free \
+ --disable-registry-download \
+ "
+