aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2024-01-10 14:42:37 +0800
committerKhem Raj <raj.khem@gmail.com>2024-01-09 22:48:25 -0800
commitdf2e4cff8e908226b0b0c61f4b5ea5c5f73be1bd (patch)
treee7e4bf7c81f885708717a7cdc7fbfc21e31c6f24 /meta-oe/recipes-kernel
parent11056735e8c2ced778ec308f9a9f52964ceefa12 (diff)
downloadmeta-openembedded-df2e4cff8e908226b0b0c61f4b5ea5c5f73be1bd.tar.gz
ipmitool: Make the version consistent
The git revison info is added [1] to make the version more descriptive to produce an incremental revision number like 1.8.18.13 or 1.8.18.14 and etc and more clear in terms of "what codebase was used" like `1.8.18.13.gee01aa5`. But it also introduces the version inconsistence. Note as stated in [1] For cases when .git directory is missing (Release compilation?) the suffix part will be omitted completely yielding a version like `1.8.18`. Considering the version we acutally used in oe is a release version, the git revision info as [1] is meaningness. So drop the git revsion info to make the version consistent. Before the patch: root@qemux86-64:~# ipmitool -V ipmitool version 1.8.19.19.gab5ce5b root@qemux86-64:~# rpm -qa | grep ipmitool ipmitool-1.8.19-r0.core2_64 After the patch: root@qemux86-64:~# ipmitool -V ipmitool version 1.8.19 root@qemux86-64:~# rpm -qa | grep ipmitool ipmitool-1.8.19-r0.core2_64 [1] https://github.com/ipmitool/ipmitool/commit/ba01dc84b4e225c86eac3f562e629662d752040f Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch42
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch b/meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch
new file mode 100644
index 0000000000..98a820bd9e
--- /dev/null
+++ b/meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch
@@ -0,0 +1,42 @@
+From 0a1af74ed3fae9a9a08b8b1ab89e88c02427ae06 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Wed, 10 Jan 2024 05:57:00 +0000
+Subject: [PATCH] csv-revision: Drop the git revision info
+
+The git revison info is added [1] to make the version more descriptive
+to produce an incremental revision number like 1.8.18.13 or 1.8.18.14
+and etc and more clear in terms of "what codebase was used" like
+`1.8.18.13.gee01aa5`. But it also introduces the below version
+inconsistence.
+ root@qemux86-64:~# ipmitool -V
+ ipmitool version 1.8.19.19.gab5ce5b
+ root@qemux86-64:~# rpm -qa | grep ipmitool
+ ipmitool-1.8.19-r0.core2_64
+
+Considering the version we acutally used in oe is a release version,
+the git revision info as [1] is meaningness. So drop the git revsion
+info to remove the above version inconsitence.
+
+[1] https://github.com/ipmitool/ipmitool/commit/ba01dc84b4e225c86eac3f562e629662d752040f
+
+Upstream-Status: Inappropriate [OE-Specific as we use a release version in oe]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ csv-revision | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/csv-revision b/csv-revision
+index 289c133..3fa9f1c 100755
+--- a/csv-revision
++++ b/csv-revision
+@@ -1,5 +1,6 @@
+ #!/bin/sh
+
++exit 0
+ git describe --first-parent --tags 2>/dev/null | (
+ IFS=- read tag rev hash
+ if [ $? ] && [ -n "$rev" ]; then
+--
+2.35.5
+
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
index a8279f5755..0f1c8846b4 100644
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
+++ b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
@@ -24,6 +24,7 @@ DEPENDS = "openssl readline ncurses"
SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
${IANA_ENTERPRISE_NUMBERS} \
+ file://0001-csv-revision-Drop-the-git-revision-info.patch \
"
IANA_ENTERPRISE_NUMBERS ?= ""