aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-31 23:20:07 -0800
committerKhem Raj <raj.khem@gmail.com>2024-01-31 23:22:09 -0800
commitdfb5a96169eb950577b31008f4563c19a94ba290 (patch)
tree4713e766d3c4cdaa1fc21fdfcc82d69ad05b1686 /meta-oe/recipes-kernel
parent02fe2e388ee9e271c3eafb07355cc5347ce76293 (diff)
downloadmeta-openembedded-dfb5a96169eb950577b31008f4563c19a94ba290.tar.gz
bpftool: Add missing dep on elfutils-native
Point host CC to OE defined BUILD_CC Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index 317ec19266..b22334fe90 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -2,7 +2,7 @@ SUMMARY = "Inspect and manipulate eBPF programs and maps"
DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
of eBPF programs and maps."
LICENSE = "GPL-2.0-only"
-DEPENDS = "binutils elfutils"
+DEPENDS = "binutils elfutils elfutils-native"
PROVIDES = "virtual/bpftool"
inherit bash-completion kernelsrc kernel-arch
@@ -15,6 +15,7 @@ EXTRA_OEMAKE = "\
O=${B} \
CROSS=${TARGET_PREFIX} \
CC="${CC} ${DEBUG_PREFIX_MAP} -fdebug-prefix-map=${STAGING_KERNEL_DIR}=${KERNEL_SRC_PATH}" \
+ HOSTCC="${BUILD_CC} ${BUILD_CFLAGS}" \
LD="${LD}" \
AR=${AR} \
ARCH=${ARCH} \