aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-15 15:04:30 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:24 +0200
commit1aaa57e8cfe8b66406ae090937129f2b9ab1155b (patch)
tree5b8ef88bf36abf1a09d7e5dd25a5e6d78fe6376a /meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
parentdcf56c9d0f6efcc2f16054bd9dda16e49105b993 (diff)
downloadmeta-openembedded-1aaa57e8cfe8b66406ae090937129f2b9ab1155b.tar.gz
engine-pkcs11: update to version 0.2.2
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb')
-rw-r--r--meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb b/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
new file mode 100644
index 0000000000..047f701102
--- /dev/null
+++ b/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
@@ -0,0 +1,31 @@
+SUMMARY = "A PKCS"
+DESCRIPTION = "\
+Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be \
+loaded using code, config file or command line and will pass any function \
+call by openssl to a PKCS cards and software for using smart cards in PKCS"
+HOMEPAGE = "https://github.com/OpenSC/engine_pkcs11"
+SECTION = "Development/Libraries"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://src/engine_pkcs11.h;startline=1;endline=26;md5=973a19f8a6105de047f2adfbbfc04c33"
+DEPENDS = "openssl libp11"
+
+SRC_URI = "git://github.com/OpenSC/engine_pkcs11.git"
+SRCREV = "132fcf2c8b319f9f4b2ebdc8dcb54ff496dc0519"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "\
+ --disable-static \
+ --libdir ${libdir}/engines \
+"
+
+do_install_append () {
+ rm -f ${D}${libdir}/engines/libpkcs11.la
+}
+
+FILES_${PN} += "${libdir}/engines/libpkcs11${SOLIBSDEV}"
+FILES_${PN}-dbg += "${libdir}/engines/.debug/"
+
+RDEPENDS_${PN} += "openssl libp11 opensc"