aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fmt
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-01-15 13:57:09 +0300
committerKhem Raj <raj.khem@gmail.com>2024-01-19 09:51:04 -0800
commit9f5b336614130b1f6f993fd21243ac4f5e957a60 (patch)
tree54d6a993afede8c23d298a377a8e277bc2bd453e /meta-oe/recipes-support/fmt
parent28cb5f1801497f505948fb2136cad260bd2188d4 (diff)
downloadmeta-openembedded-9f5b336614130b1f6f993fd21243ac4f5e957a60.tar.gz
fmt: upgrade 10.1.1 -> 10.2.1
License-Update: Dropped the rst suffix from the license file Changelog: 10.2.1 - 2024-01-03 Fixed ABI compatibility with earlier 10.x versions 10.2.0 - 2024-01-01 Added support for the %j specifier (the number of days) for std::chrono::duration Added support for the chrono suffix for days and changed the suffix for minutes from "m" to the correct "min" Fixed an overflow in std::chrono::time_point formatting with large dates Added a formatter for std::source_location Added a formatter for std::bitset Added an experimental nested_formatter that provides an easy way of applying a formatter to one or more subobjects while automatically handling width, fill and alignment. Added the generic representation (g) to std::filesystem::path Made format_as work with references Fixed formatting of invalid UTF-8 with precision Fixed an inconsistency between fmt::to_string and fmt::format Disallowed unsafe uses of fmt::styled Pass fmt::styled(...) as a parameter instead. Added a null check when formatting a C string with the s specifier. Disallowed the c specifier for bool Made the default formatting unlocalized in fmt::ostream_formatter for consistency with the rest of the library Fixed localized formatting in bases other than decimal Fixed a performance regression in experimental fmt::ostream::print Added synchronization with the underlying output stream when writing to the Windows console Changed to only export format_error when {fmt} is built as a shared library Made fmt::streamed constexpr Enabled consteval on older versions of MSVC Added an option to build without wchar_t support on Windows Improved build and CI configuration Fixed various warnings, compilation and test issues Improved documentation and README Updated CI dependencies Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fmt')
-rw-r--r--meta-oe/recipes-support/fmt/fmt_10.2.1.bb (renamed from meta-oe/recipes-support/fmt/fmt_10.1.1.bb)9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/fmt/fmt_10.1.1.bb b/meta-oe/recipes-support/fmt/fmt_10.2.1.bb
index d6706d3e7a..c2f19c43aa 100644
--- a/meta-oe/recipes-support/fmt/fmt_10.1.1.bb
+++ b/meta-oe/recipes-support/fmt/fmt_10.2.1.bb
@@ -2,15 +2,14 @@ SUMMARY = "open-source formatting library for C++"
DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
HOMEPAGE = "https://fmt.dev"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b9257785fc4f3803a4b71b76c1412729"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b9257785fc4f3803a4b71b76c1412729"
-SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https"
-SRCREV = "f5e54359df4c26b6230fc61d38aa294581393084"
+SRC_URI = "git://github.com/fmtlib/fmt;branch=10.x;protocol=https"
+SRCREV = "e69e5f977d458f2650bb346dadf2ad30c5320281"
S = "${WORKDIR}/git"
-inherit cmake
-inherit ptest
+inherit cmake ptest
EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"