aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libteam/libteam_1.28.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-01-11 01:25:07 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-11 01:46:31 -0800
commit29f47a6d736706553e0e5da1e6220ff0d2939e7a (patch)
treeb0304fb484a830acaaeff48c62e9302cbbeb8f4b /meta-oe/recipes-support/libteam/libteam_1.28.bb
parente24d03f13e336a20292d61d2e3cd1e8b78579926 (diff)
downloadmeta-openembedded-29f47a6d736706553e0e5da1e6220ff0d2939e7a.tar.gz
libteam: Upgrade to 1.28
Remove the useless checksum lines as the source is git repo, not the tar file. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libteam/libteam_1.28.bb')
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.28.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam_1.28.bb b/meta-oe/recipes-support/libteam/libteam_1.28.bb
new file mode 100644
index 0000000000..b80bb4efa8
--- /dev/null
+++ b/meta-oe/recipes-support/libteam/libteam_1.28.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Library for controlling team network device"
+HOMEPAGE = "http://www.libteam.org/"
+SECTION = "libs/network"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "libnl libdaemon jansson"
+
+SRC_URI = "git://github.com/jpirko/libteam \
+ file://0001-include-sys-select.h-for-fd_set-definition.patch \
+ file://0002-teamd-Re-adjust-include-header-order.patch \
+ file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
+ file://run-ptest \
+ "
+SRCREV = "903950c7fcf28c32f4b62d9d1c07c0234e8378a2"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig ptest
+
+FILES_${PN} = "${libdir}/libteam${SOLIBS} \
+"
+
+PACKAGES += "${PN}-dctl ${PN}-utils"
+FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \
+"
+FILES_${PN}-utils = "${bindir}/bond2team \
+ ${bindir}/teamd \
+ ${bindir}/teamdctl \
+ ${bindir}/teamnl \
+"
+
+RDEPENDS_${PN}-utils = "bash"
+RDEPENDS_${PN}-ptest = "python"
+
+do_install_ptest() {
+ install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/
+}