aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-05-16 16:13:32 +0800
committerKhem Raj <raj.khem@gmail.com>2023-05-17 17:43:24 -0700
commitda0a748ac04f71fc99e6dcf85f83a85e160c660d (patch)
treea7750fc087597bc1579db46fe6a3e011b41beab1 /meta-oe/recipes-support
parent7b55d7ef8317ba8d8405620459cd2ff903e9ff32 (diff)
downloadmeta-openembedded-da0a748ac04f71fc99e6dcf85f83a85e160c660d.tar.gz
spdlog: fix build error for master fmt
error message: include/spdlog/common.h:168:111: error: 'basic_runtime' is not a member of 'fmt' Add fix-build-for-master-fmt.patch: * update fmt_runtime_string macro * fix build of updated macro Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch44
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch b/meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch
new file mode 100644
index 0000000000..c767db919f
--- /dev/null
+++ b/meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch
@@ -0,0 +1,44 @@
+Upstream-Status: Backport
+[https://github.com/gabime/spdlog/commit/0ca574ae168820da0268b3ec7607ca7b33024d05]
+
+Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
+
+From 0ca574ae168820da0268b3ec7607ca7b33024d05 Mon Sep 17 00:00:00 2001
+From: H1X4 <10332146+H1X4Dev@users.noreply.github.com>
+Date: Fri, 31 Mar 2023 20:39:32 +0300
+Subject: [PATCH] fix build for master fmt (non-bundled) (#2694)
+
+* fix build for master fmt (non-bundled)
+
+* update fmt_runtime_string macro
+
+* fix build of updated macro
+---
+ include/spdlog/common.h | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/include/spdlog/common.h b/include/spdlog/common.h
+index e69201a81..5f671c5c6 100644
+--- a/include/spdlog/common.h
++++ b/include/spdlog/common.h
+@@ -173,12 +173,19 @@ using format_string_t = fmt::format_string<Args...>;
+ template<class T>
+ using remove_cvref_t = typename std::remove_cv<typename std::remove_reference<T>::type>::type;
+
++template <typename Char>
++#if FMT_VERSION >= 90101
++using fmt_runtime_string = fmt::runtime_format_string<Char>;
++#else
++using fmt_runtime_string = fmt::basic_runtime<Char>;
++#endif
++
+ // clang doesn't like SFINAE disabled constructor in std::is_convertible<> so have to repeat the condition from basic_format_string here,
+ // in addition, fmt::basic_runtime<Char> is only convertible to basic_format_string<Char> but not basic_string_view<Char>
+ template<class T, class Char = char>
+ struct is_convertible_to_basic_format_string
+ : std::integral_constant<bool,
+- std::is_convertible<T, fmt::basic_string_view<Char>>::value || std::is_same<remove_cvref_t<T>, fmt::basic_runtime<Char>>::value>
++ std::is_convertible<T, fmt::basic_string_view<Char>>::value || std::is_same<remove_cvref_t<T>, fmt_runtime_string<Char>>::value>
+ {};
+
+ # if defined(SPDLOG_WCHAR_FILENAMES) || defined(SPDLOG_WCHAR_TO_UTF8_SUPPORT)
diff --git a/meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb b/meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb
index ec985fb039..2800be4784 100644
--- a/meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb
+++ b/meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ad
SRCREV = "ad0e89cbfb4d0c1ce4d097e134eb7be67baebb36"
SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x \
file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch \
+ file://fix-build-for-master-fmt.patch \
"
DEPENDS += "fmt"