aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAlex Yao <alexyao1@meraki.com>2023-04-25 11:27:54 -0700
committerKhem Raj <raj.khem@gmail.com>2023-04-25 13:54:36 -0700
commite66ae31c9522a6acf42720edb7623a93407a983a (patch)
treeae4afec4b9533e9ed6db744cfd69490df38f6895 /meta-oe/recipes-support
parent0b9305faa29f6e26871e7662391efbaae4ae92d9 (diff)
downloadmeta-openembedded-e66ae31c9522a6acf42720edb7623a93407a983a.tar.gz
lcov: Fix Perl Path
Fixes an issue where lcov is using the system Perl rather than the yocto provided Perl. This causes packages to not be found during runtime such as PerlIO::gzip. Signed-off-by: Alex Yao <alexyao1@meraki.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rwxr-xr-xmeta-oe/recipes-support/lcov/lcov_1.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/lcov/lcov_1.14.bb b/meta-oe/recipes-support/lcov/lcov_1.14.bb
index 47062cca52..f18c7b18eb 100755
--- a/meta-oe/recipes-support/lcov/lcov_1.14.bb
+++ b/meta-oe/recipes-support/lcov/lcov_1.14.bb
@@ -59,7 +59,7 @@ SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
do_install() {
- oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
+ oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir} LCOV_PERL_PATH="/usr/bin/env perl"
}
BBCLASSEXTEND = "native nativesdk"