aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorchenheyun <chen_heyun@163.com>2024-03-27 06:08:12 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-27 07:57:30 -0700
commit02b230b7f42a4009e082bac00b66c8d66691047a (patch)
tree9d527c1a2197918d49c3f3ddd7ecd2f8c62b0564 /meta-oe
parent9660163c4f9e3af42312f1d53d91b73c477b6aef (diff)
downloadmeta-openembedded-02b230b7f42a4009e082bac00b66c8d66691047a.tar.gz
aer-inject:add new recipe
aer-inject allows to inject PCIE AER errors on the software level into a running Linux kernel. This is intended for validation of the PCIE driver error recovery handler and CIE AER core handler. References: https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/ Signed-off-by: chenheyun <chen_heyun@163.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
new file mode 100644
index 0000000000..fbc6bdfbed
--- /dev/null
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Inject PCIE AER errors on the software level into a running Linux kernel."
+DESCRIPTION = "\
+aer-inject allows to inject PCIE AER errors on the software \
+level into a running Linux kernel. This is intended for \
+validation of the PCIE driver error recovery handler and \
+PCIE AER core handler."
+HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/"
+SECTION = "pcie/misc"
+LICENSE = "GPL-2.0-only"
+
+LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;protocol=https;branch=master \
+"
+SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "bison-native"
+
+do_compile() {
+ oe_runmake CFLAGS="-Wall -D_GNU_SOURCE"
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr/' install
+}
+FILES:${PN} += "/usr/aer-inject"
+BBCLASSEXTEND = "native nativesdk" \ No newline at end of file