aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPaul Gortmaker <paul.gortmaker@windriver.com>2017-02-20 13:24:52 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-22 13:16:54 +0100
commit0d77dcf5c81d511bcefad6670a1dd2726f1ff2da (patch)
tree890f72f31b369afff8d3691d75efb71a98f0d1bf /meta-oe
parent129596c4837c5fcf07b88c59df1fa21095f4e441 (diff)
downloadmeta-openembedded-0d77dcf5c81d511bcefad6670a1dd2726f1ff2da.tar.gz
farsight: fix implicit pkgconfig dependency causing configure fail
In the config log we see: configure:12277: checking whether to build static libraries configure:12281: result: yes configure:12419: checking for x86_64-overc-linux-pkg-config configure:12452: result: no configure:12462: checking for pkg-config configure:12495: result: no configure:12801: Using Farsight2 source release as package name configure:12825: Using Unknown package origin as package origin configure:12879: Using /usr/libexec/gst-install-plugins-helper as plugin install helper configure:12953: checking for NICE configure:13022: error: Need libnice >= 0.0.9 While it libnice that fails configure, it is the absence of pkg-config several lines above that causes the failure, as libnice is in the sysroot. For most build hosts, you'll have to remove the default binary that lives in /usr/bin/pkg-config in order to see this failure. Cc: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/farsight/farsight2_0.0.22.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb b/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
index a9ed0919a6..2fdb12cc50 100644
--- a/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
+++ b/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
@@ -9,7 +9,7 @@ PR = "r3"
DEPENDS = "libnice glib-2.0 libxml2 zlib dbus gstreamer gst-plugins-base"
-inherit autotools
+inherit autotools pkgconfig
PACKAGECONFIG ??= ""
PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"