aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-30 10:12:41 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-30 10:17:48 -0700
commit7e196d2c3a99ad2ad88c789e0e5eb3e4b91dadc4 (patch)
treebb2b552738c3670e91d11921e82ebee2c03b7057 /meta-oe
parent0b663c4f9ae0fc2d6b2d7cda4baff4b00059a52d (diff)
downloadmeta-openembedded-7e196d2c3a99ad2ad88c789e0e5eb3e4b91dadc4.tar.gz
yasm: Add recipe ( previously in oe-core )
Remove in OE-Core via http://git.openembedded.org/openembedded-core/commit/?id=b7f3f7ecfdf26129c5df2d3ee14e73c4633ea5a3 while apps in OE-core have move to use nasm or other things yasm is still needed by some apps in rest of OE universe e.g. firefox switch to github URI since master has bunch of fixes over 1.3.0 release Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/yasm/yasm_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/yasm/yasm_git.bb b/meta-oe/recipes-devtools/yasm/yasm_git.bb
new file mode 100644
index 0000000000..b685b42412
--- /dev/null
+++ b/meta-oe/recipes-devtools/yasm/yasm_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "x86 (SSE) assembler supporting NASM and GAS-syntaxes"
+LICENSE = "BSD"
+HOMEPAGE = "http://www.tortall.net/projects/yasm/"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=a12d8903508fb6bfd49d8d82c6170dd9"
+
+PV = "1.3.0+git${SRCPV}"
+SRCREV = "35af9720e36df19382a57be26643b0d6bb48a363"
+SRC_URI = "git://github.com/yasm/yasm.git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools gettext
+
+export CCLD_FOR_BUILD = "${CC_FOR_BUILD}"
+
+BBCLASSEXTEND = "native"