aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 15:37:09 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 18:52:51 -0700
commitb175cf714b1e619b7b8a6a85891442deb0363fdb (patch)
tree50c2d338e136eb94d15875173a651bb31aa4ddbc /meta-oe
parentd0736e800df0f4af95dd87c9d15c1a6ae76d1a03 (diff)
downloadmeta-openembedded-b175cf714b1e619b7b8a6a85891442deb0363fdb.tar.gz
sanlock: Fix build with musl >= 1.2.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch32
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 0000000000..439ffc6473
--- /dev/null
+++ b/meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,32 @@
+From c955ac2a4d57f21351e53a5209346fdc2325a747 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 25 Mar 2024 15:12:02 -0700
+Subject: [PATCH] include libgen.h for basename
+
+basename prototype has been removed from string.h from latest musl [1]
+compilers e.g. clang-18 flags the absense of prototype as error. therefore
+include libgen.h for providing it.
+
+[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ wdmd/main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/wdmd/main.c b/wdmd/main.c
+index 38a99f3..7014462 100644
+--- a/wdmd/main.c
++++ b/wdmd/main.c
+@@ -15,6 +15,7 @@
+ #include <stddef.h>
+ #include <grp.h>
+ #include <fcntl.h>
++#include <libgen.h>
+ #include <string.h>
+ #include <errno.h>
+ #include <limits.h>
+--
+2.44.0
+
diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb
index 91b1460ff7..1d0f8b0103 100644
--- a/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb
@@ -16,8 +16,9 @@ PV .= "+git"
SRC_URI = "git://pagure.io/sanlock.git;protocol=http;branch=master \
file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch \
file://0001-add-missing-system-header-string.h.patch \
+ file://0001-include-libgen.h-for-basename.patch \
"
-SRCREV = "90156f382c2508cc7dc4dc32f8247d3e1291b318"
+SRCREV = "ecf30a1ccf756776dfea440e4cf9b0b54581075f"
S = "${WORKDIR}/git"