aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPeter Bergin <peter.bergin@windriver.com>2023-05-23 14:05:23 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-23 15:04:38 -0700
commitea516e9563e5c827466fd8ca674e5ab1cc8cd5f9 (patch)
treeb661870789dc46e973b68b6a5ab0315bc1a729c6 /meta-oe
parentfa1910548c33d60bb6b9023c805aa54bef77150d (diff)
downloadmeta-openembedded-ea516e9563e5c827466fd8ca674e5ab1cc8cd5f9.tar.gz
redis-plus-plus: clean up recipe and make use of packageconfig
Remove unneeded statements in the code. Align with style guide. Introduce PACKAGECONFIG for ssl and test. Remove QA warning. Signed-off-by: Peter Bergin <peter.bergin@windriver.com> Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
index 8e906a4483..8483331fa4 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
@@ -4,6 +4,8 @@ SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+DEPENDS += "hiredis"
+
SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
file://0001-include-cstdint.patch"
SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262"
@@ -12,13 +14,13 @@ S = "${WORKDIR}/git"
inherit cmake
-EXTRA_OECMAKE += "-DREDIS_PLUS_PLUS_USE_TLS=ON"
-
-DEPENDS += "hiredis openssl"
-
-RDEPENDS:${PN} += "hiredis"
-
-FILES_SOLIBSDEV = ""
-FILES:${PN} += " ${libdir}/libredis++.so*"
+# if ssl is enabled for redis-plus-plus it must also be enabled for hiredis
+PACKAGECONFIG ??= "ssl"
+PACKAGECONFIG[ssl] = "-DREDIS_PLUS_PLUS_USE_TLS=ON, -DREDIS_PLUS_PLUS_USE_TLS=OFF, openssl"
+PACKAGECONFIG[test] = "-DREDIS_PLUS_PLUS_BUILD_TEST=ON, -DREDIS_PLUS_PLUS_BUILD_TEST=OFF"
-INSANE_SKIP:${PN} += "dev-so"
+do_install:append() {
+ # To remove absolute path in .cmake found by QA warning [buildpaths]
+ sed -i -e 's|${STAGING_LIBDIR}/libcrypto.so|crypto|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake
+ sed -i -e 's|${STAGING_LIBDIR}/libssl.so|ssl|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake
+}