aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-07-31 07:22:08 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-18 11:38:08 +0200
commit011d69713c7c8439ffccba49c61c72f64e4b52da (patch)
treebaa730a496f5f1c018ba541c4ed5c4f4fe37bfdb /meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb
parentf7c67960b4faebc8048a11c47661e4d85400bd25 (diff)
downloadmeta-openembedded-011d69713c7c8439ffccba49c61c72f64e4b52da.tar.gz
libmodule-pluggable-perl: Update to 5.2
* Convert from Module::Build to ExtUtils::MakeMaker * Temporarily use github repository until change is merged upstream Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb b/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb
new file mode 100644
index 0000000000..76cac5089a
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.2.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Automatically give your module the ability to have plugins"
+DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
+having 'plugins' for your module. Obviously this isn't going to be the \
+be all and end all of solutions but it works for me.\
+\
+Essentially all it does is export a method into your namespace that \
+looks through a search path for .pm files and turn those into class \
+names.\
+\
+Optionally it instantiates those classes for you."
+SECTION = "libs"
+
+AUTHOR = "Simon Wistow <simon@thegestalt.org>"
+HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
+
+SRCNAME = "Module-Pluggable"
+SRC_URI = "https://github.com/moto-timo/${SRCNAME}/archive/${PV}.tar.gz"
+SRC_URI[md5sum] = "e32475d6ff5843f738cedacd3b7a2cdb"
+SRC_URI[sha256sum] = "58c62292eea6d06959eba1b97598650813211265403242d57efb2f605c96059f"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-base \
+ perl-module-deprecate \
+ perl-module-file-basename \
+ perl-module-file-find \
+ perl-module-file-spec \
+ perl-module-file-spec-functions \
+ perl-module-if \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"
+