aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-10-30 18:44:33 -0700
committerKhem Raj <raj.khem@gmail.com>2022-10-30 23:01:26 -0700
commit74c84f4c1159310e8e1e03d20a57aa4ab009fc9d (patch)
tree7b84e58f061d5923f2de5a40e615e2f7bfa55dd8 /meta-perl
parent0b3e25a3c13f6b896838986899940e0ed986d148 (diff)
downloadmeta-openembedded-74c84f4c1159310e8e1e03d20a57aa4ab009fc9d.tar.gz
libio-compress*-perl: cleanup; fixes
* Fix hardcoded PV in SRC_URI * Use README for LIC_FILES_CHKSUM * Fix HOMEPAGE * Add SUMMARY * Use upstream README for DESCRIPTION * Correct libcompression-*-perl RDEPENDS * Fix RDEPENDS Handy on-target check for dependencies: for path in $(find /usr/lib/perl5/vendor_perl/5.36.0/IO -name *.pm | sed -e 's~/usr/lib/perl5/vendor_perl/5.36.0/~~' -e 's~/~::~g' -e 's~.pm~~'); do perl -M${path} -e'print'; done Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb23
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb39
2 files changed, 40 insertions, 22 deletions
diff --git a/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb b/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb
index 15952f17e6..09ed161d2e 100644
--- a/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb
@@ -1,24 +1,25 @@
-DESCRIPTION = "This module provides a Perl interface that allows writing lzma compressed \
-data to files or buffer."
-
+SUMMARY = "Perl interface to allow reading and writing of lzma files/buffers."
+DESCRIPTION = "This module provides a Perl interface to allow reading and \
+writing of lzma files/buffers."
+HOMEPAGE = "https://metacpan.org/release/IO-Compress-Lzma"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-MAINTAINER= "Poky <poky@yoctoproject.org>"
-HOMEPAGE= "https://metacpan.org/release/IO-Compress-Lzma"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
-file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=2d411393b876fe63f9f1d546363f1a47"
-SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/IO-Compress-Lzma-2.096.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-Lzma-${PV}.tar.gz"
SRC_URI[md5sum] = "6c1b70740605b8073e4fbb5ba1e7bbdb"
SRC_URI[sha256sum] = "2f29125f19bb41d29c4b5a2467e3560b7bce5d428176a046b7c8a51609dce6e8"
-RDEPENDS:${PN} += "compress-raw-lzma-perl"
-RDEPENDS:${PN} += "libio-compress-perl"
S = "${WORKDIR}/IO-Compress-Lzma-${PV}"
inherit cpan
+RDEPENDS:${PN} += "\
+ perl-module-autoloader \
+ libcompress-raw-lzma-perl \
+ libio-compress-perl \
+"
+
BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb b/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb
index c00d8945b7..ea120b8246 100644
--- a/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb
@@ -1,24 +1,41 @@
-DESCRIPTION = "This module is not intended for direct use in application code. Its sole \
-purpose is to be sub-classed by IO::Compress modules."
-
+SUMMARY = "Perl interface to allow reading and writing of compressed data."
+DESCRIPTION = "This distribution provides a Perl interface to allow reading \
+and writing of compressed data created with the zlib and bzip2. \
+\
+IO-Compress supports reading and writing of the following compressed data \
+formats \
+ * bzip2 \
+ * RFC 1950 \
+ * RFC 1951 \
+ * RFC 1952 (i.e. gzip) \
+ * zip \
+"
+HOMEPAGE = "https://metacpan.org/release/IO-Compress"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-MAINTAINER= "Poky <poky@yoctoproject.org>"
-HOMEPAGE= "https://metacpan.org/release/IO-Compress"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
-file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=36e282c4a4078cf2650d656cdda23210"
-SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/IO-Compress-2.096.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz"
SRC_URI[md5sum] = "18ad197cad5ca87bc3a7d2538998e017"
SRC_URI[sha256sum] = "9d219fd5df4b490b5d2f847921e3cb1c3392758fa0bae9b05a8992b3620ba572"
-RDEPENDS:${PN} += "compress-raw-bzip2-perl"
-RDEPENDS:${PN} += "compress-raw-zlib-perl"
S = "${WORKDIR}/IO-Compress-${PV}"
inherit cpan
+RDEPENDS:${PN} += "\
+ perl-module-bytes \
+ perl-module-cwd \
+ perl-module-encode \
+ perl-module-file-glob \
+ perl-module-file-spec \
+ perl-module-posix \
+ perl-module-scalar-util \
+ perl-module-utf8 \
+ libcompress-raw-bzip2-perl \
+ libcompress-raw-zlib-perl \
+"
+
BBCLASSEXTEND = "native"