aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-automat
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-09 19:55:10 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-09 23:02:39 -0800
commit6b9db4343afbd611179ab2d10e19970d32fc8ed8 (patch)
tree63e33467f439059733bcd09e2eb3e0506169ccb0 /meta-python/recipes-devtools/python/python-automat
parent04cd18f1d986daa3e7b9802e55d33d03429db4d6 (diff)
downloadmeta-openembedded-6b9db4343afbd611179ab2d10e19970d32fc8ed8.tar.gz
python3-automat: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-automat')
-rw-r--r--meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch b/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch
deleted file mode 100644
index c29b659bc3..0000000000
--- a/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 33b70266930c9093712173c4e0c419815b55e313 Mon Sep 17 00:00:00 2001
-From: Derek Straka <derek@asterius.io>
-Date: Fri, 22 Dec 2017 09:07:00 -0500
-Subject: [PATCH] setup.py: remove the dependency on m2r
-
-The dependency on m2r is removed here as it only provides the
-long_description value that is optional. This item is just the
-text that would be present on PyPi, so it doesn't provide much
-value in this case
-
-Upstream-Status: Inappropriate (OE specific)
-
-Signed-off-by: Derek Straka <derek@asterius.io>
-
----
- setup.py | 10 ----------
- 1 file changed, 10 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index d360c64..7b4180a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -4,14 +4,6 @@ Setup file for automat
-
- from setuptools import setup, find_packages
-
--try:
-- from m2r import parse_from_file
-- long_description = parse_from_file('README.md')
--except(IOError, ImportError):
-- print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n")
-- import io
-- long_description = io.open('README.md', encoding="utf-8").read()
--
- setup(
- name='Automat',
- use_scm_version=True,
-@@ -19,12 +11,10 @@ setup(
- description="""
- Self-service finite-state machines for the programmer on the go.
- """.strip(),
-- long_description=long_description,
- packages=find_packages(exclude=[]),
- package_dir={'automat': 'automat'},
- setup_requires=[
- 'setuptools-scm',
-- 'm2r',
- ],
- install_requires=[
- "attrs>=16.1.0",