aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-10 15:56:25 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:41:26 -0800
commitcf16ca5c772f1bd0172df3745d737cdacb132272 (patch)
treed63fbc66f3f1583b69dd9ca3ad9f38cdb440714d /meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb
parente18df4e2999cb4e61e55deb7e8765411971bf2b1 (diff)
downloadmeta-openembedded-cf16ca5c772f1bd0172df3745d737cdacb132272.tar.gz
python-grpcio: update to version 1.8.3
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb b/meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb
new file mode 100644
index 0000000000..ab0b85c5a0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.8.3.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Google gRPC"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+
+DEPENDS = "python-protobuf"
+
+SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
+
+RDEPENDS_${PN} = "python-enum34 \
+ python-futures \
+ python-protobuf \
+ python-setuptools \
+ python-six \
+"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "a611ac877a1e613ba7dc24dc06d9bf88"
+SRC_URI[sha256sum] = "6ce5fd3093ddc09a152981d5c477ac645eda19dfcc819e45d8c57da6b743bd53"
+
+# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
+BBCLASSEXTEND = "native"