aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-06-28 16:45:15 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-29 08:22:57 -0700
commit835200ff1679ae792d52a4ca7c4f3585089dc611 (patch)
treee6034ec9729c701eda92d7ccc906e2029edf0f85 /meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
parente8cb41c0866568fa31271ed8bfe96b0335a9456f (diff)
downloadmeta-openembedded-835200ff1679ae792d52a4ca7c4f3585089dc611.tar.gz
python3-ansicolors: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb b/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
index 9ba710cb78..a9ebebeef9 100644
--- a/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
+++ b/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
@@ -7,6 +7,18 @@ SRC_URI[sha256sum] = "99f94f5e3348a0bcd43c82e5fc4414013ccc19d70bd939ad71e0133ce9
PYPI_PACKAGE_EXT = "zip"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test/test.py ${D}${PTEST_PATH}/
+}
BBCLASSEXTEND = "native nativesdk"