aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-09 19:12:36 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-09 23:02:39 -0800
commit999b334c6c459f47f1e89abba6aac094b73755d8 (patch)
treea14e6bf1add6ef85cdaabbc6995d20fe253e123c /meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
parent036169ad7b9efa5995c3460b0c25ca306a888b41 (diff)
downloadmeta-openembedded-999b334c6c459f47f1e89abba6aac094b73755d8.tar.gz
python3-anyjson: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
index 199e225b23..91c66724f5 100644
--- a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
@@ -1,2 +1,13 @@
-inherit setuptools3
-require python-anyjson.inc
+SUMMARY = "Wraps the best available JSON implementation available in a common interface"
+DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \
+provides a uniform API regardless of which JSON implementation is used."
+HOMEPAGE = "https://bitbucket.org/runeh/anyjson"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c"
+SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-simplejson"