aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-02-07 00:04:35 +0100
committerKhem Raj <raj.khem@gmail.com>2021-02-09 08:49:12 -0800
commit16ccd857f224e3fac4ac32ddef5727c06e1fe866 (patch)
treec9bf0b18d100c2ae45f1e96641236019937261b7 /meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb
parent9ed4bea30b3e45b2d994b7eec25bd0206d1f1da0 (diff)
downloadmeta-openembedded-16ccd857f224e3fac4ac32ddef5727c06e1fe866.tar.gz
python3-aws-iot-device-sdk-python: update to 1.4.9
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb
deleted file mode 100644
index f763067cf0..0000000000
--- a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "SDK for connecting to AWS IoT using Python."
-HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
-LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
-LICENSE_${PN}-examples = "Apache-2.0"
-LIC_FILES_CHKSUM = "\
- file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
- file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
-"
-
-SRC_URI[md5sum] = "d05596f02774ea39517765c5dced874a"
-SRC_URI[sha256sum] = "bcd68cb7fdb044dbd5e5d3a02c311b25717c0376168e7c992982130f19c51b03"
-
-inherit pypi setuptools3
-
-PYPI_PACKAGE = "AWSIoTPythonSDK"
-
-do_install_append() {
- install -d -m0755 ${D}${datadir}/${BPN}/examples
- cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
- # this requires the full blown AWS Python SDK
- rm -r ${D}${datadir}/${BPN}/examples/basicPubSub
-}
-
-PACKAGES =+ "${PN}-examples"
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-crypt \
- ${PYTHON_PN}-datetime \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-json \
- ${PYTHON_PN}-logging \
- ${PYTHON_PN}-math \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-threading \
-"
-RDEPENDS_${PN}-examples += "${PN}"
-
-FILES_${PN}-examples = "${datadir}/${BPN}/examples"
-
-BBCLASSEXTEND = "native nativesdk"