aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-03-07 15:11:19 +0200
committerKhem Raj <raj.khem@gmail.com>2022-03-07 09:27:53 -0800
commit5f11eefb8d72e41645e7ce9971440d3246aace65 (patch)
tree9a9cf9b80c77c7f164ed40ba6934dcf824670ad9 /meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
parent5e114797545c593e238675d5b15734c367f9ff77 (diff)
downloadmeta-openembedded-5f11eefb8d72e41645e7ce9971440d3246aace65.tar.gz
python3-bandit: Upgrade 1.7.2 -> 1.7.4
Upgrade to release 1.7.4: - Fix traceback in hashlib_insecure_functions - Add version 1.7.3 to dropdown - core/config: Fix ConfigError missing argument if toml is missing - Add 1.7.4 in issue template Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb b/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
new file mode 100644
index 0000000000..cfdbde9689
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Security oriented static analyser for python code."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI[sha256sum] = "2d63a8c573417bae338962d4b9b06fbc6080f74ecd955a092849e1e65c717bd2"
+
+DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+inherit setuptools3 pypi
+
+RDEPENDS:${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+BBCLASSEXTEND = "native"