aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-click_7.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:52:06 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitd5df1fe869a9a746438a6ad8c208a170357e7e5a (patch)
treebebcdcacd5cd921d0a91a88a9308142361464b63 /meta-python/recipes-devtools/python/python3-click_7.0.bb
parentc3d10cd377406fa3ce7286965bfe64c1b1c67a90 (diff)
downloadmeta-openembedded-d5df1fe869a9a746438a6ad8c208a170357e7e5a.tar.gz
python3-click: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-click_7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-click_7.0.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click_7.0.bb b/meta-python/recipes-devtools/python/python3-click_7.0.bb
index 1920644042..cfa3e0fe4f 100644
--- a/meta-python/recipes-devtools/python/python3-click_7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-click_7.0.bb
@@ -1,2 +1,26 @@
+SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
+DESCRIPTION = "\
+Click is a Python package for creating beautiful command line interfaces \
+in a composable way with as little code as necessary. It's the "Command \
+Line Interface Creation Kit". It's highly configurable but comes with \
+sensible defaults out of the box."
+HOMEPAGE = "http://click.pocoo.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c13ed890b210a882c1778216694c98c7"
+
+SRC_URI[md5sum] = "7f53d50f7b7373ebc7963f9ff697450a"
+SRC_URI[sha256sum] = "5b94b49521f6456670fdb30cd82a4eca9412788a93fa6dd6df72c94d5a8ff2d7"
+
+PYPI_PACKAGE = "Click"
inherit pypi setuptools3
-require python-click.inc
+
+UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
+
+CLEANBROKEN = "1"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-threading \
+ "
+
+BBCLASSEXTEND = "native nativesdk"