aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-01-07 14:58:20 +0200
committerKhem Raj <raj.khem@gmail.com>2022-01-10 10:35:02 -0800
commitdf5c1a31fdb8325d1c514f9ed8a7b3805dc581ac (patch)
treefa133bfde84be78c40eedd70e4932b124edc08b8 /meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
parentf37e388c358e0c4dac5ee041f25e2510c91bb155 (diff)
downloadmeta-openembedded-df5c1a31fdb8325d1c514f9ed8a7b3805dc581ac.tar.gz
python3-diskcache: Upgrade 5.3.0 -> 5.4.0
Upgrade to release 5.4.0: - Run isort - Remove unused imports - Update tests for Django 3.2 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb b/meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
new file mode 100644
index 0000000000..84d42e5722
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Disk Cache -- Disk and file backed persistent cache."
+HOMEPAGE = "http://www.grantjenks.com/docs/diskcache/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c60ef82f0f40155453f6d5f2c94b6e8e"
+
+SRC_URI[sha256sum] = "8879eb8c9b4a2509a5e633d2008634fb2b0b35c2b36192d89655dbde02419644"
+
+PYPI_PACKAGE = "diskcache"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-threading \
+"
+
+CLEANBROKEN = "1"