aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-28 16:51:27 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-02 08:50:49 -0700
commitaf7566197dc75b8e320143acbd50b142c2f05cbb (patch)
treecc54e8155bab2fa7822ee94d2c8b9d8d90c79f72 /meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb
parentb1c837d4d440071bb32ae2a627260822fd63e3cf (diff)
downloadmeta-openembedded-af7566197dc75b8e320143acbd50b142c2f05cbb.tar.gz
python3-ecdsa: Upgrade 0.15 -> 0.16.0
Upgrade to release 0.16.0: - Support for reading and writing private keys in PKCS#8 format. - to_pem and to_der now accept new parameter, format, to specify the format of the encoded files, either the dafault, legacy "ssleay", or the new pkcs8 to use PKCS#8. Note that only unencrypted PKCS#8 files are supported - Add allow_truncate to verify in VerifyingKey, it defaults to True, when specified as False, use of large hashes smaller than curves will be disallowed (as it was in 0.14.1 and earlier) - Correctly calculate signatures for private keys equal to n-1 - Make PointJacobi and thus SigningKey and VerifyingKey pickleable - to_pem functions return bytes not str, document them as such - from_pem and from_pem in SigningKey returns SigningKey, document them as such - Ensure that version checks will work with Python 4. - Format the source with black. - Fix uses of assert_ in test suite. - Use newer Ubuntu in Travis to test against OpenSSL 1.1.1 (and thus test the interoperability of ECDH code in Travis). Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb
new file mode 100644
index 0000000000..36bb246fdf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.16.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "ECDSA cryptographic signature library (pure python)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
+
+DEPENDS += "python3-pip python3-pbr"
+
+PYPI_PACKAGE = "ecdsa"
+SRC_URI[md5sum] = "d593df1ab57da611dca76f7328c47b21"
+SRC_URI[sha256sum] = "494c6a853e9ed2e9be33d160b41d47afc50a6629b993d2b9c5ad7bb226add892"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-six python3-gmpy2 python3-pbr"