aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:42 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commit6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c (patch)
treeefd62458ef4652877d2f8482b4c2133d2c3d0fa3 /meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
parentbecd9ec57a7b38279ea79708f583a5b2eba3f30d (diff)
downloadmeta-openembedded-6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c.tar.gz
python3-eth-utils: new package
Add a recipe for eth-utils: utility functions for codebases which interact with ethereum. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb b/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
new file mode 100644
index 0000000000..ff7caf5bf2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Common utility functions for codebases which interact with ethereum."
+HOMEPAGE = "https://github.com/ethereum/eth-utils"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=287820ad3553117aa2f92bf84c219324"
+
+SRC_URI[sha256sum] = "32f50edb14c5be0c4f0e8c2e6117286ccc5dfda21d170f358add554a048398e3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-eth-hash \
+ python3-eth-typing \
+ python3-setuptools \
+ python3-toolz \
+"