aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-20 13:10:25 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-25 14:34:06 -0800
commitb9fce31173df46e556c66efb4c025111ccff3ed4 (patch)
tree25f707819133af996d5a877e89b92826f8202b42 /meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
parentd085d1887b68880887089d458ebd37f22b0e9f2c (diff)
downloadmeta-openembedded-b9fce31173df46e556c66efb4c025111ccff3ed4.tar.gz
python3-evdev: Upgrade 1.3.0 -> 1.4.0
Upgrade to release 1.4.0: - Fix InputDevice.set_absinfo to allow setting parameters to zero. - Fix off-by-one in ioctl_EVIOCG_bits, which causes value at the end of the list to not be reported back. - Fix set_absinfo to allow setting parameters to zero. - Fix leak when returning BlockingIOError from a read. - Fix "There is no current event loop in thread" error for non asyncio code. - Prevent InputDevice destructor from blocking. - Add missing return codes to os.strerror() calls and fix force feedback example in docs (#138). - Add the util.find_ecodes_by_regex() helper function. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb b/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
deleted file mode 100644
index fe11049ad1..0000000000
--- a/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "Python evdev lib"
-HOMEPAGE = "https://github.com/gvalkov/python-evdev"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
-
-SRC_URI[md5sum] = "05f9e900d6e11e1674475d2dd2668f0d"
-SRC_URI[sha256sum] = "b1c649b4fed7252711011da235782b2c260b32e004058d62473471e5cd30634d"
-
-inherit pypi setuptools3
-
-do_compile_prepend() {
- rm -rf ${S}/evdev/ecodes.c
-}
-
-DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-ctypes \
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-stringold \
- "