aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-25 13:15:44 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-28 09:02:47 -0700
commit5ad4e64af5f84df95c1d925b5b7b57db74df1203 (patch)
treea09e7f3c2d870b75e27af40ce4ea652a270d7dff /meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb
parentacf1fc64ad7cbb4905677ba737bd6e8c123659ef (diff)
downloadmeta-openembedded-5ad4e64af5f84df95c1d925b5b7b57db74df1203.tar.gz
python3-googleapis-common-protos: Add recipe
Add common protobufs used in Google APIs. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb b/meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb
new file mode 100644
index 0000000000..2c59ae86d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-googleapis-common-protos_1.53.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Common protobufs used in Google APIs"
+HOMEPAGE = "https://github.com/googleapis/python-api-common-protos"
+AUTHOR = "Google LLC"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "a88ee8903aa0a81f6c3cec2d5cf62d3c8aa67c06439b0496b49048fb1854ebf4"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-grpcio \
+ ${PYTHON_PN}-protobuf \
+"