aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-24 17:50:01 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:34:14 -0700
commit4876bdb197c2f816b6de04dff4e987eda03935fa (patch)
tree10e04ddf530f50d2dfe45babef43642ded999c6d /meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
parenteb1710d8b6e0e46695d0a74a176206731ea99cdb (diff)
downloadmeta-openembedded-4876bdb197c2f816b6de04dff4e987eda03935fa.tar.gz
python3-inflection: Upgrade 0.5.0 -> 0.5.1
Upgrade to release 0.5.1: - Fix type hints not working Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
new file mode 100644
index 0000000000..b5cde669ff
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A port of Ruby on Rails' inflection to Python."
+HOMEPAGE = "https://pypi.org/project/inflection"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31"
+
+SRC_URI[md5sum] = "c3287d4f0e3bdf625a52d655cc514403"
+SRC_URI[sha256sum] = "1a29730d366e996aaacffb2f1f1cb9593dc38e2ddd30c91250c6dde09ea9b417"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI +=" \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}_ptest +=" \
+ ${PYTHON_PN}_pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/
+}
+
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pytest"
+
+BBCLASSEXTEND = "native nativesdk"