aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-25 16:26:29 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-27 15:07:17 -0700
commitfca320293e8d93ae8da02dce1dc22dcf9d9e6b7a (patch)
tree68b9d0e3b9b84c181d4bdb8ab833f09ce4f11c90 /meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb
parent407a63b4a5c607d351fc66cfda76f587c3c81101 (diff)
downloadmeta-openembedded-fca320293e8d93ae8da02dce1dc22dcf9d9e6b7a.tar.gz
python3-openpyxl: Upgrade 3.0.4 -> 3.0.5
Upgrade to release 3.0.5 with the following bugfixes: - Incorrectly consider currency format as datetime - Cannot copy worksheets with merged cells - Empty worksheets do not return generators when looping - Hyperlinks duplicated on multiple saves - Incorrectly literal format as datetime - Links set to range of cells not preserved - Exception when opening workbook with chartsheets and tables Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb b/meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb
new file mode 100644
index 0000000000..0aa9fb020d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-openpyxl_3.0.5.bb
@@ -0,0 +1,15 @@
+SUMMARY = "openpyxl is a Python library to read/write Excel 2010 xlsx/xlsm/xltx/xltm files"
+DESCRIPTION = "It was born from lack of existing library to read/write natively \
+from Python the Office Open XML format. All kudos to the PHPExcel team as openpyxl \
+was initially based on PHPExcel."
+
+HOMEPAGE = "http://www.python-excel.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "526b7149538575d58e55df1bd37807c1"
+SRC_URI[sha256sum] = "18e11f9a650128a12580a58e3daba14e00a11d9e907c554a17ea016bf1a2c71b"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-jdcal ${PYTHON_PN}-et-xmlfile"