aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-09-08 12:53:43 -0400
committerKhem Raj <raj.khem@gmail.com>2021-09-10 06:55:20 -0700
commit4b9bceea4cbb39a3b0564f394b357d6b36887ae1 (patch)
tree292052509d7b15c2d20dc79cab0d16e1eb901bcb /meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb
parentfc46c809529f4b5d83ade972c91d388b302b6f48 (diff)
downloadmeta-openembedded-4b9bceea4cbb39a3b0564f394b357d6b36887ae1.tar.gz
python3-pillow: upgrade 8.3.1 -> 8.3.2
From the release notes: - CVE-2021-23437: Avoid a potential ReDoS (regular expression denial of service) in ImageColor’s getrgb() by raising ValueError if the color specifier is too long. Present since Pillow 5.2.0. - Fix 6-byte out-of-bounds (OOB) read. The previous bounds check in FliDecode.c incorrectly calculated the required read buffer size when copying a chunk, potentially reading six extra bytes off the end of the allocated buffer from the heap. Present since Pillow 7.1.0. This bug was found by Google’s OSS-Fuzz CIFuzz runs. - Pillow now includes binary wheels for Python 3.10. - Ensure TIFF RowsPerStrip is multiple of 8 for JPEG compression (#5588). - Updates for ImagePalette channel order (#5599). - Hide FriBiDi shim symbols to avoid conflict with real FriBiDi library (#5651). Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb b/meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb
new file mode 100644
index 0000000000..68b80a7392
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pillow_8.3.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
+Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
+Contributors."
+HOMEPAGE = "https://pillow.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0337b116233da4616ae9fdb130bf6f1a"
+
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=8.3.x \
+ file://0001-support-cross-compiling.patch \
+ file://0001-explicitly-set-compile-options.patch \
+"
+SRCREV ?= "8013f130a5077b238a4346b73e149432b180a8ea"
+
+inherit setuptools3
+
+DEPENDS += " \
+ zlib \
+ jpeg \
+ tiff \
+ freetype \
+ lcms \
+ openjpeg \
+"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"
+
+CVE_PRODUCT = "pillow"
+
+S = "${WORKDIR}/git"
+
+RPROVIDES:${PN} += "python3-imaging"
+
+BBCLASSEXTEND = "native"