aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-09-05 17:09:44 +0300
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:34 -0700
commit1830c04a549b73a8775d883a32c1af19597430a4 (patch)
treea319a92449e0092c54b92dccfdf8fee6809177b4 /meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb
parentf76554cb589370e4f22a68e79b71769b57ae197b (diff)
downloadmeta-openembedded-1830c04a549b73a8775d883a32c1af19597430a4.tar.gz
python3-prompt-toolkit: Upgrade 3.0.30 -> 3.0.31
Upgrade to release 3.0.31: - Pass through `name` property in `TextArea` widget to `Buffer`. - Added a `enable_cpr` parameter to `Vt100_Output`, `TelnetServer` and `PromptToolkitSSHServer`, to completely disable CPR support instead of automatically detecting it. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb
new file mode 100644
index 0000000000..0b8962dedf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Library for building powerful interactive command lines in Python"
+HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
+
+SRC_URI[sha256sum] = "9ada952c9d1787f52ff6d5f3484d0b4df8952787c087edf6a1f7c2cb1ea88148"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "prompt_toolkit"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-wcwidth \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-image \
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-xml \
+"
+
+BBCLASSEXTEND = "native nativesdk"