aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-15 18:24:47 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-16 12:10:05 -0700
commit21a29fa0abd273e9b5b6b99d7d555c4c2225b358 (patch)
tree7edfb50817a073e8940c4a1ea1a85c2f4e6cb12b /meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb
parentb9cee05f04f4aa71e7fe25f3bebc5621d9b6f824 (diff)
downloadmeta-openembedded-21a29fa0abd273e9b5b6b99d7d555c4c2225b358.tar.gz
python3-psutil: Upgrade 5.7.0 -> 5.7.2
Upgrade to release 5.7.2: - wheels for 2.7 were inadvertently deleted. - parallel tests on UNIX (make test-parallel). They're twice as fast! - "make build/install" is now run in parallel and it's about 15% faster on UNIX. - Process.wait() on POSIX returns an enum, showing the negative signal which was used to terminate the process. - Process.wait() return value is cached so that the exit code can be retrieved on then next call. - memory leak tests are now stable. - Linux: cpu_freq() parsing should use spaces instead of tabs on ia64. - Linux: Process.rlimit() does not handle long long type properly. - fix signature of callback function for getloadavg(). Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb b/meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb
new file mode 100644
index 0000000000..d61d501e9c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
+
+PYPI_SRC_URI = "https://files.pythonhosted.org/packages/aa/3e/d18f2c04cf2b528e18515999b0c8e698c136db78f62df34eee89cee205f1/psutil-${PV}.tar.gz"
+SRC_URI[md5sum] = "50bf39b4faa268ba1da8a9730bb38bb6"
+SRC_URI[sha256sum] = "90990af1c3c67195c44c9a889184f84f5b2320dce3ee3acbd054e3ba0b4a7beb"
+
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
+"
+
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"