aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-05 17:16:30 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-08 08:41:09 -0800
commit78cf804178fe4eec0b714ed89597230fb478b91e (patch)
tree393308e15048b6bf48b06c18c0dfe7342294d491 /meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb
parentc0e6098cf0c1863442f00ae0471e54fa36ad5bd8 (diff)
downloadmeta-openembedded-78cf804178fe4eec0b714ed89597230fb478b91e.tar.gz
python3-psutil: Upgrade 5.7.3 -> 5.8.0
Upgrade to release 5.8.0: - disk_partitions() exposes 2 extra fields: maxfile and maxpath, which are the maximum file name and path name length. - [Windows] added support for PyPy 2.7. - provide pre-compiled wheels for Linux and macOS. - get rid of Travis and Cirrus CI services (they are no longer free). CI testing is now done by GitHub Actions on Linux, macOS and FreeBSD (yes). AppVeyor is still being used for Windows CI. - [Linux] get rid of sensors_temperatures() duplicates. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb b/meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb
new file mode 100644
index 0000000000..bd43b414d0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
+
+SRC_URI[sha256sum] = "0c9ccb99ab76025f2f0bbecf341d4656e9c1351db8cc8a03ccd62e318ab4b5c6"
+
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
+"
+
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"