aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-22 15:59:30 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-23 10:45:31 -0700
commitb32b4347244b043f442b860550c21f78f34f5e5c (patch)
tree5f465d4cb7340c45f5d808884c75dc73908b41f9 /meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
parentfa2d3338fb87a38a66d11735b876ce2320045b0d (diff)
downloadmeta-openembedded-b32b4347244b043f442b860550c21f78f34f5e5c.tar.gz
meta-python: Add python3-fastjsonschema and its dependencies
python3-fastjsonschema claims to be fastest Python implementation of JSON schema it however needs additional packages which are also added here, since they are all dependent, its added in single commit so backporting is simpler Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
new file mode 100644
index 0000000000..1f81a83230
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
@@ -0,0 +1,20 @@
+# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Get CPU info with pure Python 2 & 3"
+HOMEPAGE = "https://github.com/workhorsy/py-cpuinfo"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b0b97c022f12b14d9e02de0b283ee9e9"
+
+SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell"
+
+# WARNING: We were unable to map the following python package/module
+# dependencies to the bitbake packages which include them:
+# _winreg
+# cStringIO
+# winreg
+BBCLASSEXTEND = "native nativesdk"