aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-17 14:11:27 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-19 09:16:54 -0700
commitbe3f005dd79b3ebb8663ca3367d87db0ed60d8a0 (patch)
tree970e470eb373316ea74c6de17f60902c5ab35bab /meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb
parent3ab0e0db1696af674dbf11d6152663ddefd7fb88 (diff)
downloadmeta-openembedded-be3f005dd79b3ebb8663ca3367d87db0ed60d8a0.tar.gz
python3-pyjwt: Upgrade 2.0.1 -> 2.1.0
Upgrade to release 2.1.0: - Allow claims validation without making JWT signature validation mandatory - Remove padding from JWK test data - Make kty mandatory in JWK to be compliant with RFC7517 - Allow JWK without alg to be compliant with RFC7517 - Allow to verify with private key on ECAlgorithm, as well as on Ed25519Algorithm - Add caching by default to PyJWKClient - Add missing exceptions.InvalidKeyError to jwt module __init__ imports - Add support for ES256K algorithm - Add from_jwk() to Ed25519Algorithm - Add to_jwk() to Ed25519Algorithm - Export PyJWK and PyJWKSet Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb b/meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb
new file mode 100644
index 0000000000..f1486f4773
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_2.1.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "JSON Web Token implementation in Python"
+DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
+ Original implementation was written by https://github.com/progrium"
+HOMEPAGE = "http://github.com/jpadilla/pyjwt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
+
+SRC_URI[sha256sum] = "fba44e7898bbca160a2b2b501f492824fc8382485d3a6f11ba5d0c1937ce6130"
+
+PYPI_PACKAGE = "PyJWT"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native nativesdk"