aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2022-09-27 17:35:22 +0800
committerKhem Raj <raj.khem@gmail.com>2022-09-28 14:54:31 -0700
commitfcc0bd434488343a9c0c901b46433f7190095a41 (patch)
tree344f24fd250bcc9aff81b7b67bf4d216ee01fa59 /meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb
parent9805d38ea86fde795c07016a4740dfb392aaa851 (diff)
downloadmeta-openembedded-fcc0bd434488343a9c0c901b46433f7190095a41.tar.gz
python3-pyjwt: upgrade 2.4.0 -> 2.5.0
Changelog: ========== Bump actions/checkout from 2 to 3 Bump codecov/codecov-action from 1 to 3 Bump actions/setup-python from 2 to 3 adding support for compressed payloads Revert "adding support for compressed payloads" Add to_jwk static method to ECAlgorithm Remove redundant wheel dep from pyproject.toml Adjust expected exceptions in option merging tests for PyPy3 Do not fail when an unusable key occurs Fixes for pyright on strict mode Bump actions/setup-python from 3 to 4 [pre-commit.ci] pre-commit autoupdate docs: fix simple typo, iinstance -> isinstance Expose get_algorithm_by_name as new method Remove support for python3.6 [pre-commit.ci] pre-commit autoupdate Emit a deprecation warning for unsupported kwargs Fix typo: priot -> prior Fix for headers disorder issue Update audience typing Improve PyJWKSet error accuracy Add type hints to jwt/help.py and add missing types dependency Add cacheing functionality for JWK set [pre-commit.ci] pre-commit autoupdate Mypy as pre-commit check + api_jws typing [pre-commit.ci] pre-commit autoupdate Bump version to 2.5.0 Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb
new file mode 100644
index 0000000000..f587e5c0de
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "JSON Web Token implementation in Python"
+DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
+ Original implementation was written by https://github.com/progrium"
+HOMEPAGE = "http://github.com/jpadilla/pyjwt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551"
+
+SRC_URI[sha256sum] = "e77ab89480905d86998442ac5788f35333fa85f65047a534adc38edf3c88fc3b"
+
+PYPI_PACKAGE = "PyJWT"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native nativesdk"