aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-24 18:37:44 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-26 10:32:32 -0700
commit1d0cdcb2885647f5c7c54db202efeeaa98388441 (patch)
tree2fb02b1121e0294054193c9b96e4b49f921e28ce /meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb
parent8de7638b23b9cfe338abdcb42b2a5901d4b406eb (diff)
downloadmeta-openembedded-1d0cdcb2885647f5c7c54db202efeeaa98388441.tar.gz
python3-pyperf: Upgrade 2.1.0 -> 2.2.0
Upgrade to release 2.2.0: - --track-memory option now supports macOS by using psutil. - Added --copy-env command line option that inherits all environment variables. - The development branch master was renamed to main. See https://sfconservancy.org/news/2020/jun/23/gitbranchname/ for the rationale. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb b/meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb
new file mode 100644
index 0000000000..70676b05f3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperf_2.2.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[sha256sum] = "498bb4d1fe21350c2b7c1aa8bb3eae9c9979358d0b66327954bc66839fcba8b6"
+
+DEPENDS += "${PYTHON_PN}-six-native"
+
+PYPI_PACKAGE = "pyperf"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-misc"