aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-28 14:25:22 +0800
committerKhem Raj <raj.khem@gmail.com>2022-11-28 11:32:26 -0800
commit73d8f924b7a1d9f56f9bcb9dd2795f5088ceef00 (patch)
tree6f2f8be3bf711111808b32e3db7108b1cab22120 /meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb
parent68f9b6eb7f20afd6f2ff2eccc230bc41ef6fb006 (diff)
downloadmeta-openembedded-73d8f924b7a1d9f56f9bcb9dd2795f5088ceef00.tar.gz
python3-pyperf: upgrade 2.4.1 -> 2.5.0
Changelog: =========== Recognize new name of Graal-based Python as jitted Collect specialization statistics from running benchmarks Add support for Python 3.11 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb
new file mode 100644
index 0000000000..d5eaa4f607
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperf_2.5.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[sha256sum] = "9fd9be5b57224e68b5a5b88f7126f15b6c8667573f62a0a39faf14d6fdd13909"
+
+DEPENDS += "${PYTHON_PN}-six-native"
+
+PYPI_PACKAGE = "pyperf"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "${PYTHON_PN}-misc ${PYTHON_PN}-statistics"