aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-07-05 09:56:13 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-06 09:40:42 -0700
commit43b5311980f4328588604a06b34f53927052c96a (patch)
treee4b90e10387691a21ef781d84ae60e715f52d47e /meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
parenteb7030939983dc4fc5dfb29e4f0ef4e4b4d3f505 (diff)
downloadmeta-openembedded-43b5311980f4328588604a06b34f53927052c96a.tar.gz
python3-pyrsistent: upgrade 0.17.3 -> 0.18.0
0.18.0, 2021-06-28 * Fix #209 Update freeze recurse into pyrsistent data structures and thaw to recurse into lists and dicts, Thanks @phil-arh for this! NB! This is a backwards incompatible change! To keep the old behaviour pass `strict=False` to freeze and thaw. * Fix #226, stop using deprecated exception.message. Thanks @hexagonrecursion for this! * Fix #211, add union operator to persistent maps. Thanks @bowbahdoe for this! * Fix #194, declare build dependencies through pyproject.toml. Thanks @jaraco for this! * Officially drop Python 3.5 support. * Fix #223, release wheels for all major platforms. Thanks @johnthagen for helping out with this! * Fix #221, KeyError obscured by TypeError if key is a tuple. Thanks @ganwell for this! * Fix LICENSE file name spelling. Thanks @ndowens and @barentsen for this! * Fix #216, add abstractmethod decorator for CheckedType and ABCMeta for _CheckedTypeMeta. Thanks @ss18 for this! * Fix #228, rename example classes in tests to avoid name clashes with pytest. -License-Update: Copyright year updated to 2021. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb b/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
new file mode 100644
index 0000000000..7b792284e2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=a4b94c2b800b582a8d3925a9939cbf44"
+
+SRC_URI[sha256sum] = "773c781216f8c2900b42a7b638d5b517bb134ae1acbebe4d1e8f1f41ea60eb4b"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"