aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyserial_3.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.5.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
index 4be80e28cd..4766d92266 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
@@ -6,7 +6,7 @@ SRC_URI[sha256sum] = "3c77e014170dfffbd816e6ffc205e9842efb10be9f58ec16d3e8675b49
inherit pypi setuptools3 ptest
-do_install_append() {
+do_install:append() {
rm -f ${D}${bindir}/pyserial-miniterm
rm -f ${D}${bindir}/pyserial-ports
rmdir ${D}${bindir}
@@ -14,17 +14,17 @@ do_install_append() {
PACKAGES =+ "${PN}-java ${PN}-osx ${PN}-win32 ${PN}-tools"
-FILES_${PN}-java = " \
+FILES:${PN}-java = " \
${PYTHON_SITEPACKAGES_DIR}/serial/*java* \
${PYTHON_SITEPACKAGES_DIR}/serial/__pycache__/*java* \
"
-FILES_${PN}-osx = " \
+FILES:${PN}-osx = " \
${PYTHON_SITEPACKAGES_DIR}/serial/tools/*osx* \
${PYTHON_SITEPACKAGES_DIR}/serial/tools/__pycache__/*osx* \
"
-FILES_${PN}-win32 = " \
+FILES:${PN}-win32 = " \
${PYTHON_SITEPACKAGES_DIR}/serial/*serialcli* \
${PYTHON_SITEPACKAGES_DIR}/serial/__pycache__/*serialcli* \
${PYTHON_SITEPACKAGES_DIR}/serial/*win32* \
@@ -35,7 +35,7 @@ FILES_${PN}-win32 = " \
${PYTHON_SITEPACKAGES_DIR}/serial/tools/__pycache__/*windows* \
"
-RDEPENDS_${PN} = "\
+RDEPENDS:${PN} = "\
${PYTHON_PN}-fcntl \
${PYTHON_PN}-io \
${PYTHON_PN}-logging \
@@ -52,7 +52,7 @@ SRC_URI += " \
file://run-ptest \
"
-RDEPENDS_${PN}-ptest += " \
+RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"